5th Annual Montes at the Glen!

Club events and gatherings.
User avatar
battmann
Site Admin
Posts: 908
Joined: Mon Apr 25, 2011 8:02 pm
Location: North Chili, NY

Re: 5th Annual Montes at the Glen!

Post by battmann » Thu Apr 14, 2016 7:19 pm

We're taking the kids to great wolf lodge in Canada this weekend.

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Thu Apr 14, 2016 8:41 pm

Have Fun Clint! Never been there, but heard it's pretty cool.

Pete, it would have been fun for you to get the Monte out for a good run at the Glen.
There is no such thing as Too Many Montes

User avatar
petegee77
Posts: 1867
Joined: Sat Jun 11, 2011 6:08 pm
Location: Kenmore

Re: 5th Annual Montes at the Glen!

Post by petegee77 » Fri Apr 15, 2016 6:42 pm

twomanymontes wrote:Have Fun Clint! Never been there, but heard it's pretty cool.

Pete, it would have been fun for you to get the Monte out for a good run at the Glen.
Yeah she needs a good run but we're going to Elmira next weekend. Not crazy about that trip on back to back weekends.
Nothing but Mopars Image

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Sun Apr 17, 2016 5:03 pm

We broke some records today for sure! We had 29 vehicles in our group and one of them was a Honda minivan!!! Track was smooth! And we were not as fast as in the past, but it was still moving right along. Matt found out he needs to start braking a little earlier at turn 1. A guess he missed the wall by a foot! I got behind a slow car and could only make it to 89 mph before I nearly rear ended him. Tim's car ran and handled better than ever, and I still need to make some adjustments.

Can't wait till next year!!!!

Of course, I broke my camera, so as soon as someone else posts some pics, I will post them up here.
There is no such thing as Too Many Montes

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Sun Apr 17, 2016 6:19 pm

https://youtu.be/oz67xFVNtB8?t=49
Just glad our weekend didn't end up like this. This was at Silverstone Today!
There is no such thing as Too Many Montes

User avatar
petegee77
Posts: 1867
Joined: Sat Jun 11, 2011 6:08 pm
Location: Kenmore

Re: 5th Annual Montes at the Glen!

Post by petegee77 » Mon Apr 18, 2016 8:47 pm

twomanymontes wrote:We broke some records today for sure! We had 29 vehicles in our group and one of them was a Honda minivan!!! Track was smooth! And we were not as fast as in the past, but it was still moving right along. Matt found out he needs to start braking a little earlier at turn 1. A guess he missed the wall by a foot! I got behind a slow car and could only make it to 89 mph before I nearly rear ended him. Tim's car ran and handled better than ever, and I still need to make some adjustments.

Can't wait till next year!!!!

Of course, I broke my camera, so as soon as someone else posts some pics, I will post them up here.
Sounds like you had a great time, especially with the new track surface.
Nothing but Mopars Image

User avatar
petegee77
Posts: 1867
Joined: Sat Jun 11, 2011 6:08 pm
Location: Kenmore

Re: 5th Annual Montes at the Glen!

Post by petegee77 » Mon Apr 18, 2016 8:48 pm

twomanymontes wrote:https://youtu.be/oz67xFVNtB8?t=49
Just glad our weekend didn't end up like this. This was at Silverstone Today!
Amazing that he was able to walk away.
Nothing but Mopars Image

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Tue Apr 19, 2016 9:07 pm

petegee77 wrote:
twomanymontes wrote:https://youtu.be/oz67xFVNtB8?t=49
Just glad our weekend didn't end up like this. This was at Silverstone Today!
Amazing that he was able to walk away.

Just goes to show how safe these cars are.
There is no such thing as Too Many Montes

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Tue Apr 19, 2016 9:09 pm

petegee77 wrote:
twomanymontes wrote:We broke some records today for sure! We had 29 vehicles in our group and one of them was a Honda minivan!!! Track was smooth! And we were not as fast as in the past, but it was still moving right along. Matt found out he needs to start braking a little earlier at turn 1. A guess he missed the wall by a foot! I got behind a slow car and could only make it to 89 mph before I nearly rear ended him. Tim's car ran and handled better than ever, and I still need to make some adjustments.

Can't wait till next year!!!!

Of course, I broke my camera, so as soon as someone else posts some pics, I will post them up here.
Sounds like you had a great time, especially with the new track surface.
Image

Yeah, it was a blast!! I just need to get better brakes and tires for next year.
There is no such thing as Too Many Montes

User avatar
petegee77
Posts: 1867
Joined: Sat Jun 11, 2011 6:08 pm
Location: Kenmore

Re: 5th Annual Montes at the Glen!

Post by petegee77 » Wed Apr 20, 2016 3:27 pm

Thanks for the picture
Nothing but Mopars Image

User avatar
twomanymontes
Posts: 1938
Joined: Tue Apr 26, 2011 6:18 pm
Location: Amherst, NY
Contact:

Re: 5th Annual Montes at the Glen!

Post by twomanymontes » Wed Apr 20, 2016 7:21 pm

I will post more. Working on posting a video I took.
There is no such thing as Too Many Montes

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest